Monday, December 17, 2012

SQL Server Management Studio IntelliSense Doesn't Work

I have recently worked on several Dynamics GP SQL Server 2008 servers where the IntelliSense feature in SQL Server Management Studio was not working.

I would type "SELECT * FROM RM", expecting to get a list of RM tables, but nothing would happen.

Ever since I noticed the problem at a client, I seem to notice it happening all of the time, even on my own development servers, where I know IntelliSense normally works.

It seems that there are at least two general causes of this issue.  In the first case, for some reason the IntelliSense "local cache" has an issue or isn't setup.  To resolve that, try and refresh the IntelliSense cache by going to Edit -> IntelliSense -> Refresh Local Cache. 

After choosing this menu option, wait several seconds, and then try typing a query to see if IntelliSense starts working.  That seems to work for me most of the time.  I don't know why I have to do it occasionally on my SQL Servers, but it's easy enough.

In other cases there may be an issue with SQL Server.  At one client, the TEST server had an older SQL service pack level and apparently there were some IntelliSense issues resolved in a newer service pack.  But I've read other articles that tell you to dig around and make some changes in Management Studio or in Windows.  None of those instructions happened to work for me, but you can give them a try if Refresh Local Cache doesn't work.

Here are a few discussions of the issue:

Steve Endow is a Dynamics GP Certified Trainer and Dynamics GP Certified IT Professional in Los Angeles.  He is also the owner of Precipio Services, which provides Dynamics GP integrations, customizations, and automation solutions.

No comments: